This page was exported from Furor Teutonicus [ https://www.furorteutonicus.eu ]
Export date: Sun Dec 5 8:40:02 2021 / +0000 GMT

Videokaart geeft zwart scherm in POST & BIOS fase


Ooit kocht ik een aantal AMD Radeon RX 580 videokaarten van XFX om wat mee te spelen in een multi-GPU rig, o.a. om Ethereum mee te delven, en eigenlijk wilde ik ook wat spelen met neurale netwerken. Dat kostte me destijds meer stroomkosten dan het opleverde; de videokaarten gingen in de reserve. Onlangs zette ik er weer eentje in een van mijn computers. Vanwege een verhuizing leef ik nu op een enkele locatie i.p.v. twee, dus de computers richt ik een beetje anders in.

Tijdens de bootup (POST = Power On Self Test, BIOS = Basic Input/Output System) had ik een zwart scherm. Pas na het laden van het OS en de grafische driver kreeg ik het inlogscherm van Linux of Windows. Maar de BIOS instellingen en de bootloader waren letterlijk op zwart gezet. (Eigenlijk is het tegenwoordig geen BIOS meer maar UEFI.)

Na wat zoekwerk begreep ik dat moderne videokaarten (GPU's) een eigen VBIOS hebben, waar het BIOS van het moederbord gebruik van maakt. En dat VBIOS komt in twee varianten: de ouderwetse, en een nieuwere UEFI versie. Oudere moederborden werken niet altijd goed met UEFI en dan moet je de CMS module inschakelen (Compatibility Support Module). Echter, ik heb een behoorlijk recent moederbord.

Soms helpt het om de laatste Windows driver te installeren om firmware te updaten. Dat heb ik gedaan, maar dat hielp niet. Met ATIFlash kon ik ook zien dat de firmware (VBIOS) ongemoeid bleef.

Ineens bedacht ik me dat deze videokaarten uitgerust zijn met twee VBIOS versies: een "default" voor normaal gebruik, en een "mining" versie. Met een schuifknopje kun je instellen welke versie gebruikt wordt. Het schuifknopje stond op "mining". Terugzetten op "default" gaf me weer normaal beeld tijdens de POST en daarna.

AMD Radeon RX 580 _ XFX _ VBIOS switch (default or mining)

Mocht je dus ooit zoiets gebeuren, en waarschijnlijk ben je hier via Google of DuckDuckGo gekomen, verschuif dat knopje dan. Als het knopje naar achteren schuift, dus van de videoconnectors weg en naar de extra stroomaansluiting toe, dan zet je 'm op "default". Vervangende VBIOS ROM's voor de mining modus kun je met ATIFlash instellen en dan kun je het beste eerst het schuifknopje naar voren schuiven.

Als je een oud moederbord hebt, probeer dan ook 's CMS in te schakelen, mocht dat nog niet gebeurd zijn.
Excerpt: Een zwart scherm tijdens het opstarten van de computer; pas als Linux of Windows opgestart is ook beeld. Hoe lossen we dat op?
Post date: 2021-11-14 18:29:13
Post date GMT: 2021-11-14 17:29:13
Post modified date: 2021-11-14 19:10:11
Post modified date GMT: 2021-11-14 18:10:11
Powered by [ Universal Post Manager ] plugin. HTML saving format developed by gVectors Team www.gVectors.com